unified

Project: remarkjs/remark-lint

Package: remark-preset-lint-consistent@5.1.1

  1. Dependents: 17
  2. remark preset to configure remark-lint with rules that enforce consistency
  1. remark 195
  2. preset 5
  3. remark-preset 4

remark-preset-lint-consistent

Build Coverage Downloads Size Sponsors Backers Chat

Preset of remark-lint rules to warn for inconsistencies.

Contents

What is this?

This package is a unified (remark) preset, specifically consisting of remark-lint rules. Lint rules check markdown code style.

When should I use this?

You can use this package to check that markdown is consistent.

Rules

This preset configures remark-lint with the following rules:

RuleSetting
remark-lint-blockquote-indentation'consistent'
remark-lint-checkbox-character-style'consistent'
remark-lint-code-block-style'consistent'
remark-lint-emphasis-marker'consistent'
remark-lint-fenced-code-marker'consistent'
remark-lint-heading-style'consistent'
remark-lint-link-title-style'consistent'
remark-lint-list-item-content-indent
remark-lint-ordered-list-marker-style'consistent'
remark-lint-rule-style'consistent'
remark-lint-strong-marker'consistent'
remark-lint-table-cell-padding'consistent'

Install

This package is ESM only. In Node.js (version 12.20+, 14.14+, or 16.0+), install with npm:

npm install remark-preset-lint-consistent

In Deno with Skypack:

import remarkPresetLintConsistent from 'https://cdn.skypack.dev/remark-preset-lint-consistent@5?dts'

In browsers with Skypack:

<script type="module">
  import remarkPresetLintConsistent from 'https://cdn.skypack.dev/remark-preset-lint-consistent@5?min'
</script>

Use

On the API:

import {read} from 'to-vfile'
import {reporter} from 'vfile-reporter'
import {remark} from 'remark'
import remarkPresetLintConsistent from 'remark-preset-lint-consistent'

main()

async function main() {
  const file = await remark()
    .use(remarkPresetLintConsistent)
    .process(await read('example.md'))

  console.error(reporter(file))
}

On the CLI:

remark --use remark-preset-lint-consistent example.md

On the CLI in a config file (here a package.json):

 …
 "remarkConfig": {
   "plugins": [
     …
+    "remark-preset-lint-consistent",
     …
   ]
 }
 …

API

This package exports no identifiers. The default export is remarkPresetLintConsistent.

unified().use(remarkPresetLintConsistent)

Use the preset. Presets don’t have options. You can reconfigure rules in them by using the afterwards with different options.

Compatibility

Projects maintained by the unified collective are compatible with all maintained versions of Node.js. As of now, that is Node.js 12.20+, 14.14+, and 16.0+. Our projects sometimes work with older versions, but this is not guaranteed.

Contribute

See contributing.md in remarkjs/.github for ways to get started. See support.md for ways to get help.

This project has a code of conduct. By interacting with this repository, organization, or community you agree to abide by its terms.

License

MIT © Titus Wormer